http://wm-monitoring.ru/ ')) {alert('Спасибо за то что установили нашу кнопку! =)');} else {alert('Очень жаль! =(');}"> http://wm-monitoring.ru/

JQuery 2.0 вышел официально!

Опубликовано: 01.09.2018

 

Популярный javascript фреймворк JQuery обновился до версии 2.0. Как и ожидалось, в новой версии отсутствует поддержка старых версий Internet Explorer, включая IE 6, 7 и 8.

Многие разработчики привыкли полагаться на JQuery , чтобы облегчить головную боль при разработке сложных, кросс-браузерных веб-интерфейсов, особенно там, где речь идет о поддержке капризных старых браузеров, худшим из которых является IE.

По некоторым подсчетам, JQuery в настоящее время используется на более чем 50 процентов всех веб-сайтов, что делает его гораздо более популярным по отношению с другими конкурирующими javascript библиотеками, такими как Dojo, MooTools, Prototype, YUI.

Начиная с JQuery 2.0, разработчики, которые хотят поддерживать старые версии IE должны будут использовать старые версии JQuery библиотек (1,9 и ниже).

Удалив код, необходимый для поддержки этих старых браузеров, разработчикам проекта удалось уменьшить размер кода библиотеки на 12 процентов при одновременном повышении его производительности. Код уменьшился за счет удаления скриптов, отвечающих за поддержку старых версий браузера IE. Однако, как заявляют сами разработчики, код можно было еще уменьшить за счет отказа поддержки Android 2.х, но доля данной мобильной операционной системы еще высока, но в будущем это обязательно произойдет:

"Android / WebKit 2.x браузеры в настоящее время являются самым слабым звеном", пишут разработчики. "Мы внимательно следим за рыночной долей Android 2.x, чтобы определить, когда мы можем прекратить его поддержку."

Тем веб-разработчикам, которые до сих пор нуждаются в поддержке IE 6, 7 или 8 версии должны продолжать использовать 1.x библиотеку JQuery, которай все еще поддерживается разработчиками. Данная библиотека в настоящее время имеет версию 1.9, которая будет обновлена до 1,10 в течение нескольких месяцев.

JQuery API 2.0 - совместим с JQuery 1.9, а разработчики проекта говорят, что планируют поддерживать функцию паритета между двумя ветвями библиотеки, из этого следует, что библиотека версии 1.10 будет кратна 2.0, а 1.11 будет соответствовать 2.1, и так далее.

 

Задействовать новую библиотеку jQuery 2.0 можно следующим образом:

 

<SCRIPT src="http://code.jquery.com/jquery-2.0.0.min.js"></ SCRIPT> <SCRIPT src="http://code.jquery.com/jquery-2.0.0.js"></ SCRIPT>

 

Карта
rss